<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Bye bye Travis CI | daniel.haxx.se</title>
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://daniel.haxx.se/blog/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/js/html5.js?ver=3.7.0"></script>
	<![endif]-->
	<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="daniel.haxx.se &raquo; Feed" href="https://daniel.haxx.se/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="daniel.haxx.se &raquo; Comments Feed" href="https://daniel.haxx.se/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="daniel.haxx.se &raquo; Bye bye Travis CI Comments Feed" href="https://daniel.haxx.se/blog/2021/06/14/bye-bye-travis-ci/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/daniel.haxx.se\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://daniel.haxx.se/blog/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://daniel.haxx.se/blog/wp-includes/css/dist/block-library/theme.min.css?ver=5.7.2' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='https://daniel.haxx.se/blog/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://daniel.haxx.se/blog/wp-includes/css/dashicons.min.css?ver=5.7.2' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='https://daniel.haxx.se/blog/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/genericons/genericons.css?ver=3.0.3' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css'  href='https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/style.css?ver=20190507' media='all' />
<link rel='stylesheet' id='twentyfourteen-block-style-css'  href='https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/css/ie.css?ver=20140701' media='all' />
<![endif]-->
<script src='https://daniel.haxx.se/blog/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script src='https://daniel.haxx.se/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://daniel.haxx.se/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://daniel.haxx.se/blog/wp-json/wp/v2/posts/16901" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://daniel.haxx.se/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://daniel.haxx.se/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://daniel.haxx.se/blog/2021/06/14/bye-bye-travis-ci/" />
<link rel='shortlink' href='https://daniel.haxx.se/blog/?p=16901' />
<link rel="alternate" type="application/json+oembed" href="https://daniel.haxx.se/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdaniel.haxx.se%2Fblog%2F2021%2F06%2F14%2Fbye-bye-travis-ci%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://daniel.haxx.se/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdaniel.haxx.se%2Fblog%2F2021%2F06%2F14%2Fbye-bye-travis-ci%2F&#038;format=xml" />
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style type="text/css" id="twentyfourteen-header-css">
				.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
				</style>
		<link rel="icon" href="https://daniel.haxx.se/blog/wp-content/uploads/2015/08/cropped-Daniel-head-greenshirt-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://daniel.haxx.se/blog/wp-content/uploads/2015/08/cropped-Daniel-head-greenshirt-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://daniel.haxx.se/blog/wp-content/uploads/2015/08/cropped-Daniel-head-greenshirt-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://daniel.haxx.se/blog/wp-content/uploads/2015/08/cropped-Daniel-head-greenshirt-270x270.jpg" />
</head>

<body class="post-template-default single single-post postid-16901 single-format-standard wp-embed-responsive header-image singular">
<div id="page" class="hfeed site">
		<div id="site-header">
		<a href="https://daniel.haxx.se/blog/" rel="home">
			<img src="https://daniel.haxx.se/blog/wp-content/uploads/2015/08/keyword-header-thin.jpg" width="1260" height="100" alt="daniel.haxx.se">
		</a>
	</div>
	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
			<h1 class="site-title"><a href="https://daniel.haxx.se/blog/" rel="home">daniel.haxx.se</a></h1>

			<div class="search-toggle">
				<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
			</div>

			<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
				<div id="primary-menu" class="nav-menu"><ul>
<li class="page_item page-item-2"><a href="https://daniel.haxx.se/blog/about/">About this blog</a></li>
<li class="page_item page-item-8378"><a href="https://daniel.haxx.se/blog/contact/">Contact</a></li>
</ul></div>
			</nav>
		</div>

		<div id="search-container" class="search-box-wrapper hide">
			<div class="search-box">
				<form role="search" method="get" class="search-form" action="https://daniel.haxx.se/blog/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div>
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">
			
<article id="post-16901" class="post-16901 post type-post status-publish format-standard has-post-thumbnail hentry category-curl tag-ci tag-curl-and-libcurl tag-testing">
	
		<div class="post-thumbnail">
			<img width="672" height="341" src="https://daniel.haxx.se/blog/wp-content/uploads/2021/06/farewell-3258939_1920.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" />		</div>

		
	<header class="entry-header">
				<div class="entry-meta">
			<span class="cat-links"><a href="https://daniel.haxx.se/blog/category/floss/curl/" rel="category tag">cURL and libcurl</a></span>
		</div>
			<h1 class="entry-title">Bye bye Travis CI</h1>
		<div class="entry-meta">
			<span class="entry-date"><a href="https://daniel.haxx.se/blog/2021/06/14/bye-bye-travis-ci/" rel="bookmark"><time class="entry-date" datetime="2021-06-14T11:14:30+02:00">June 14, 2021</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="https://daniel.haxx.se/blog/author/daniel/" rel="author">Daniel Stenberg</a></span></span>			<span class="comments-link"><a href="https://daniel.haxx.se/blog/2021/06/14/bye-bye-travis-ci/#respond">Leave a comment</a></span>
						</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		
<p>In the afternoon of October 17, 2013 we merged the first config file ever that would use <strong>Travis CI</strong> for the curl project using the nifty integration at GitHub. This was the actual introduction of the entire concept of building and testing the project on every commit and pull request for the curl project. Before this merge happened, we only had our autobuilds. They are systems run by volunteers that update the code from git maybe once per day, build and run the tests and then upload all the logs.</p>



<p>Don&#8217;t take this wrong: the autobuilds are awesome and have helped us make curl what it is. But they rely on individuals to host and admin the machines and to setup the specific configs that are tested.</p>



<p>With the introduction of &#8220;proper&#8221; CI, the configs that are tested are now also hosted in git and allows the project members to better control and adjust the tests and configs, plus that we can run them on already on pull-requests so that we can verify code before merge instead of having to first merge the code to master before the changes can get verified.</p>



<h2>Seriously. Always.</h2>



<p>Travis provided a free service with a great promise.</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="973" height="369" src="https://daniel.haxx.se/blog/wp-content/uploads/2021/06/Screenshot_2021-05-31-Travis-CI-Test-and-Deploy-Your-Code-with-Confidence.png" alt="" class="wp-image-16918"/><figcaption>Promise from Travis website as recently as late 2020.</figcaption></figure></div>



<p></p>



<p>In 2017 we surpassed 10 jobs per commit, all still on Travis.</p>



<p>In early 2019 we reached 30 jobs per commit, and at that time we started to use and spread out the work on more CI services. Travis would still remain as the one we&#8217;d lean on the heaviest. It was there and we had custom-written a bunch of jobs for it and it performed well.</p>



<p>Travis even turned some levers for us so that we got more parallel processing powers than on the regular open source tier, and we listed them as sponsors of the curl project for their gracious help. This may or may not be related to the fact that I met Josh Kalderimis (co-founder of travis) in 2019 and we talked about curl&#8217;s use of it and they possibly helping us more.</p>



<h2>Transition to death</h2>



<p>This year, 2021, the curl project runs around 100 CI jobs per commit and PR. 33 of them ran on Travis when we were finally pushed over from travis-ci.org to their new travis-ci.com domain. A transition they&#8217;d been advertising for a while but wasn&#8217;t very clearly explained or motivated in my eyes.</p>



<p>The new domain also implied new rules and new tiers, we quickly learned. Now we would have to apply to be recognized as an open source project (after 7.5 years of using their services as an open source project). But also, in order to get to take advantage of their free tier being an open source project was no longer enough. Among the new requirements on the project was this:</p>



<blockquote class="wp-block-quote"><p><strong>Project must not be sponsored by a commercial company or<br>organization (monetary or with employees paid to work on the project)</strong></p></blockquote>



<p>We&#8217;re a small independent open source project, but yes I work on curl full-time thanks to companies paying for curl support. I&#8217;m paid to work on curl and therefore we cannot meet that requirement.</p>



<h2>Not eligible but still there</h2>



<p>I&#8217;m not sure why, but apparently we still got free &#8220;credits&#8221; for running CI on Travis. The CI jobs kept working and I think maybe I sighed a little from relief &#8211; of course I did it prematurely as it only took us a few days into the month of June until we had run out of the free credits. There&#8217;s no automatic refill but we can apparently ask for more. We asked, but many days after having asked we still had no more credits and no CI jobs could run on Travis anymore. CI on Travis at the same level as before would cost at least 249 USD/month. Maybe not so much &#8220;it will always be free&#8221;.</p>



<p>The 33 jobs on Travis were there for a purpose. They&#8217;re prerequisites for us to develop and ship a quality product. Without the CI jobs running, we risk landing bad code. This was not a sustainable situation.</p>



<p>We looked for alternative services and we quickly got several offers of help and assistance.</p>



<h2>New service</h2>



<p>Friends from both <a href="https://zuul-ci.org/">Zuul CI</a> and <a href="https://circleci.com/">Circle CI</a> stepped up and helped us started to get CI jobs transitioned over from Travis over to their new homes.</p>



<p>At June 14th 2021, we officially had no more jobs running on Travis.</p>



<p>Visualized as a graph, we can see the Travis jobs &#8220;falling off a cliff&#8221; with Zuul rising to the challenge:</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://daniel.haxx.se/blog/wp-content/uploads/2021/06/Screenshot_2021-06-14-Screenshot1.png"><img loading="lazy" width="2630" height="1479" src="https://daniel.haxx.se/blog/wp-content/uploads/2021/06/Screenshot_2021-06-14-Screenshot1.png" alt="" class="wp-image-16940"/></a></figure></div>



<p>Services come and go. There&#8217;s no need to get hung up on that fact but instead keep moving forward with our eyes fixed on the horizon.</p>



<h2>Credits</h2>



<p>Image by <a href="https://pixabay.com/users/geralt-9301/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=3258939">Gerd Altmann</a> from <a href="https://pixabay.com/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=3258939">Pixabay</a></p>
	</div><!-- .entry-content -->
	
	<footer class="entry-meta"><span class="tag-links"><a href="https://daniel.haxx.se/blog/tag/ci/" rel="tag">CI</a><a href="https://daniel.haxx.se/blog/tag/curl-and-libcurl/" rel="tag">cURL and libcurl</a><a href="https://daniel.haxx.se/blog/tag/testing/" rel="tag">testing</a></span></footer></article><!-- #post-16901 -->
		<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/" rel="prev"><span class="meta-nav">Previous Post</span>Bye bye metalink in curl</a>			</div><!-- .nav-links -->
		</nav><!-- .navigation -->
		
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/2021/06/14/bye-bye-travis-ci/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://daniel.haxx.se/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="cptch_block"><script class="cptch_to_remove">
				(function( timeout ) {
					setTimeout(
						function() {
							var notice = document.getElementById("cptch_time_limit_notice_26");
							if ( notice )
								notice.style.display = "block";
						},
						timeout
					);
				})(300000);
			</script>
			<span id="cptch_time_limit_notice_26" class="cptch_time_limit_notice cptch_to_remove">Time limit is exhausted. Please reload CAPTCHA.</span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_26"><span class="cptch_span"><input id="cptch_input_26" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;&minus;&nbsp;</span>
					<span class="cptch_span">1</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">2</span>
					<input type="hidden" name="cptch_result" value="CVE=" /><input type="hidden" name="cptch_time" value="1623675167" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='16901' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8ef2038354" /></p><input type="hidden" id="ak_js" name="ak_js" value="181"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
		</div><!-- #content -->
	</div><!-- #primary -->

<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
	
		<aside id="recent-posts-3" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1><nav role="navigation" aria-label="Recent Posts">
		<ul>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/06/14/bye-bye-travis-ci/" aria-current="page">Bye bye Travis CI</a>
											<span class="post-date">June 14, 2021</span>
									</li>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/">Bye bye metalink in curl</a>
											<span class="post-date">June 7, 2021</span>
									</li>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/05/31/curl-localhost-as-a-local-host/">curl localhost as a local host</a>
											<span class="post-date">May 31, 2021</span>
									</li>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/05/28/taking-hyper-curl-further/">Taking hyper-curl further</a>
											<span class="post-date">May 28, 2021</span>
									</li>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/05/28/giving-away-an-insane-amount-of-curl-stickers/">Giving away an insane amount of curl stickers</a>
											<span class="post-date">May 28, 2021</span>
									</li>
											<li>
					<a href="https://daniel.haxx.se/blog/2021/05/27/quic-is-rfc-9000/">QUIC is RFC 9000</a>
											<span class="post-date">May 27, 2021</span>
									</li>
					</ul>

		</nav></aside><aside id="recent-comments-3" class="widget widget_recent_comments"><h1 class="widget-title">Recent Comments</h1><nav role="navigation" aria-label="Recent Comments"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Aysha</span> on <a href="https://daniel.haxx.se/blog/2021/05/28/giving-away-an-insane-amount-of-curl-stickers/comment-page-1/#comment-25075">Giving away an insane amount of curl stickers</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://bob@example.com' rel='external nofollow ugc' class='url'>bob@example.com</a></span> on <a href="https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/comment-page-1/#comment-25053">Bye bye metalink in curl</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://daniel.haxx.se/' rel='external nofollow ugc' class='url'>Daniel Stenberg</a></span> on <a href="https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/comment-page-1/#comment-25049">Bye bye metalink in curl</a></li><li class="recentcomments"><span class="comment-author-link">Scott Lovenberg</span> on <a href="https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/comment-page-1/#comment-25047">Bye bye metalink in curl</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://daniel.haxx.se/' rel='external nofollow ugc' class='url'>Daniel Stenberg</a></span> on <a href="https://daniel.haxx.se/blog/2021/05/31/curl-localhost-as-a-local-host/comment-page-1/#comment-25002">curl localhost as a local host</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://frederic-wang.fr/' rel='external nofollow ugc' class='url'>Frédéric Wang</a></span> on <a href="https://daniel.haxx.se/blog/2021/05/31/curl-localhost-as-a-local-host/comment-page-1/#comment-25000">curl localhost as a local host</a></li><li class="recentcomments"><span class="comment-author-link">Chris Short</span> on <a href="https://daniel.haxx.se/blog/2021/05/28/giving-away-an-insane-amount-of-curl-stickers/comment-page-1/#comment-24988">Giving away an insane amount of curl stickers</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://toughjobs.org' rel='external nofollow ugc' class='url'>Drew</a></span> on <a href="https://daniel.haxx.se/blog/2021/05/27/quic-is-rfc-9000/comment-page-1/#comment-24986">QUIC is RFC 9000</a></li><li class="recentcomments"><span class="comment-author-link">Henning Habighorst</span> on <a href="https://daniel.haxx.se/blog/2021/05/20/i-could-rewrite-curl/comment-page-1/#comment-24962">&#8220;I could rewrite curl&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Metchio</span> on <a href="https://daniel.haxx.se/blog/2021/05/20/i-could-rewrite-curl/comment-page-1/#comment-24953">&#8220;I could rewrite curl&#8221;</a></li></ul></nav></aside></div><!-- #content-sidebar -->
<div id="secondary">
		<h2 class="site-description">tech, open source and networking</h2>
	
	
		<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		<aside id="custom_html-2" class="widget_text widget widget_custom_html"><h1 class="widget-title">I&#8217;m Daniel Stenberg</h1><div class="textwidget custom-html-widget"><p>	Lead developer of curl. I'm tall, Swedish and grumpy.</p>
<p>
	<a href="https://github.com/users/bagder/sponsorship">[Sponsor me on github]</a></p>
<p>	What you read here is my <i>personal</i> opinions and views. You may think differently. Organizations I'm involved with may have different stand-points and people I work with or know may think differently.</p>
<p>
	I'm <a href="https://twitter.com/bagder">@bagder</a> on twitter
</p></div></aside><aside id="calendar-3" class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>June 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="1" class="pad">&nbsp;</td><td>1</td><td>2</td><td>3</td><td>4</td><td>5</td><td>6</td>
	</tr>
	<tr>
		<td><a href="https://daniel.haxx.se/blog/2021/06/07/" aria-label="Posts published on June 7, 2021">7</a></td><td>8</td><td>9</td><td>10</td><td>11</td><td>12</td><td>13</td>
	</tr>
	<tr>
		<td id="today"><a href="https://daniel.haxx.se/blog/2021/06/14/" aria-label="Posts published on June 14, 2021">14</a></td><td>15</td><td>16</td><td>17</td><td>18</td><td>19</td><td>20</td>
	</tr>
	<tr>
		<td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td>
	</tr>
	<tr>
		<td>28</td><td>29</td><td>30</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://daniel.haxx.se/blog/2021/05/">&laquo; May</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside><aside id="archives-3" class="widget widget_archive"><h1 class="widget-title">Archive</h1>		<label class="screen-reader-text" for="archives-dropdown-3">Archive</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://daniel.haxx.se/blog/2021/06/'> June 2021 </option>
	<option value='https://daniel.haxx.se/blog/2021/05/'> May 2021 </option>
	<option value='https://daniel.haxx.se/blog/2021/04/'> April 2021 </option>
	<option value='https://daniel.haxx.se/blog/2021/03/'> March 2021 </option>
	<option value='https://daniel.haxx.se/blog/2021/02/'> February 2021 </option>
	<option value='https://daniel.haxx.se/blog/2021/01/'> January 2021 </option>
	<option value='https://daniel.haxx.se/blog/2020/12/'> December 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/11/'> November 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/10/'> October 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/09/'> September 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/08/'> August 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/07/'> July 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/06/'> June 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/05/'> May 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/04/'> April 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/03/'> March 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/02/'> February 2020 </option>
	<option value='https://daniel.haxx.se/blog/2020/01/'> January 2020 </option>
	<option value='https://daniel.haxx.se/blog/2019/12/'> December 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/11/'> November 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/10/'> October 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/09/'> September 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/08/'> August 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/07/'> July 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/06/'> June 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/05/'> May 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/04/'> April 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/03/'> March 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/02/'> February 2019 </option>
	<option value='https://daniel.haxx.se/blog/2019/01/'> January 2019 </option>
	<option value='https://daniel.haxx.se/blog/2018/12/'> December 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/11/'> November 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/10/'> October 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/09/'> September 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/08/'> August 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/07/'> July 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/06/'> June 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/05/'> May 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/04/'> April 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/03/'> March 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/02/'> February 2018 </option>
	<option value='https://daniel.haxx.se/blog/2018/01/'> January 2018 </option>
	<option value='https://daniel.haxx.se/blog/2017/12/'> December 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/11/'> November 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/10/'> October 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/09/'> September 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/08/'> August 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/06/'> June 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/05/'> May 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/04/'> April 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/03/'> March 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/02/'> February 2017 </option>
	<option value='https://daniel.haxx.se/blog/2017/01/'> January 2017 </option>
	<option value='https://daniel.haxx.se/blog/2016/12/'> December 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/11/'> November 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/10/'> October 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/09/'> September 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/08/'> August 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/07/'> July 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/06/'> June 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/05/'> May 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/04/'> April 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/03/'> March 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/02/'> February 2016 </option>
	<option value='https://daniel.haxx.se/blog/2016/01/'> January 2016 </option>
	<option value='https://daniel.haxx.se/blog/2015/12/'> December 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/11/'> November 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/10/'> October 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/09/'> September 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/08/'> August 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/07/'> July 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/06/'> June 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/05/'> May 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/04/'> April 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/03/'> March 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/02/'> February 2015 </option>
	<option value='https://daniel.haxx.se/blog/2015/01/'> January 2015 </option>
	<option value='https://daniel.haxx.se/blog/2014/12/'> December 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/11/'> November 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/10/'> October 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/09/'> September 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/08/'> August 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/07/'> July 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/06/'> June 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/05/'> May 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/04/'> April 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/03/'> March 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/02/'> February 2014 </option>
	<option value='https://daniel.haxx.se/blog/2014/01/'> January 2014 </option>
	<option value='https://daniel.haxx.se/blog/2013/12/'> December 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/11/'> November 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/10/'> October 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/08/'> August 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/07/'> July 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/06/'> June 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/04/'> April 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/03/'> March 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/02/'> February 2013 </option>
	<option value='https://daniel.haxx.se/blog/2013/01/'> January 2013 </option>
	<option value='https://daniel.haxx.se/blog/2012/12/'> December 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/11/'> November 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/10/'> October 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/09/'> September 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/08/'> August 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/07/'> July 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/06/'> June 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/05/'> May 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/04/'> April 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/03/'> March 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/02/'> February 2012 </option>
	<option value='https://daniel.haxx.se/blog/2012/01/'> January 2012 </option>
	<option value='https://daniel.haxx.se/blog/2011/12/'> December 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/11/'> November 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/10/'> October 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/09/'> September 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/08/'> August 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/07/'> July 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/06/'> June 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/05/'> May 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/04/'> April 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/03/'> March 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/02/'> February 2011 </option>
	<option value='https://daniel.haxx.se/blog/2011/01/'> January 2011 </option>
	<option value='https://daniel.haxx.se/blog/2010/12/'> December 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/11/'> November 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/10/'> October 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/09/'> September 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/08/'> August 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/07/'> July 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/06/'> June 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/05/'> May 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/04/'> April 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/03/'> March 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/02/'> February 2010 </option>
	<option value='https://daniel.haxx.se/blog/2010/01/'> January 2010 </option>
	<option value='https://daniel.haxx.se/blog/2009/12/'> December 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/11/'> November 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/10/'> October 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/09/'> September 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/08/'> August 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/07/'> July 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/06/'> June 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/05/'> May 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/04/'> April 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/03/'> March 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/02/'> February 2009 </option>
	<option value='https://daniel.haxx.se/blog/2009/01/'> January 2009 </option>
	<option value='https://daniel.haxx.se/blog/2008/12/'> December 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/11/'> November 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/10/'> October 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/09/'> September 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/08/'> August 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/07/'> July 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/06/'> June 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/05/'> May 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/04/'> April 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/03/'> March 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/02/'> February 2008 </option>
	<option value='https://daniel.haxx.se/blog/2008/01/'> January 2008 </option>
	<option value='https://daniel.haxx.se/blog/2007/12/'> December 2007 </option>
	<option value='https://daniel.haxx.se/blog/2007/11/'> November 2007 </option>
	<option value='https://daniel.haxx.se/blog/2007/10/'> October 2007 </option>
	<option value='https://daniel.haxx.se/blog/2007/09/'> September 2007 </option>
	<option value='https://daniel.haxx.se/blog/2007/08/'> August 2007 </option>

		</select>

<script>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside>	</div><!-- #primary-sidebar -->
	</div><!-- #secondary -->

		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">

			
			<div class="site-info">
												<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<script src='https://daniel.haxx.se/blog/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script src='https://daniel.haxx.se/blog/wp-content/themes/twentyfourteen/js/functions.js?ver=20171218' id='twentyfourteen-script-js'></script>
<script src='https://daniel.haxx.se/blog/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script async="async" src='https://daniel.haxx.se/blog/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"3f72b27e81","ajaxurl":"https:\/\/daniel.haxx.se\/blog\/wp-admin\/admin-ajax.php","enlarge":"0"};
</script>
<script src='https://daniel.haxx.se/blog/wp-content/plugins/captcha/js/front_end_script.js?ver=5.7.2' id='cptch_front_end_script-js'></script>
</body>
</html>
